# CVE-2025-1022: Browsershot Path Traversal

> Attackers can read arbitrary local files by bypassing input validation in the setHtml function of the spatie/browsershot library.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2025
- **Updated:** 23 Aug 2026
- **Also known as:** GHSA-j2gw-r24m-j2qw

## What is CVE-2025-1022?

CVE-2025-1022 is a high-severity path traversal vulnerability in spatie/browsershot, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package spatie/browsershot before 5.0.5 are vulnerable to Improper Input Validation in the setHtml function, invoked by Browsershot::html(), which can be bypassed by omitting the slashes in the file URI (e.g., file:../../../../etc/passwd). This is due to missing validations of the user input that should be blocking file URI schemes (e.g., file:// and file:/) in the HTML content.**Note:** Further analysis has identified additional proof-of-concept exploits leveraging the vulnerable function. Developers using this package should ensure proper input validation to mitigate potential risks, as the issue remains unaddressed.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-1022?

2 open source packages ship an affected version, including spatie/browsershot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spatie/browsershot` | Packagist | All versions | 5.0.5 |
| `spatie/browsershot` | Packagist | All versions | 5.0.5 |

## How do I fix CVE-2025-1022?

Upgrade spatie/browsershot to 5.0.5 or later.

## Is CVE-2025-1022 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1022 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1022 and fix it if it is affected.

What it is: CVE-2025-1022 is a high-severity path traversal vulnerability in spatie/browsershot, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1022 exists.

Affected packages and fixed versions:
- spatie/browsershot (Packagist): affected all versions; fixed in 5.0.5
- spatie/browsershot (Packagist): affected all versions; fixed in 5.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1022/ (Markdown: https://insights.sbomify.com/CVE-2025-1022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1022
- OSV: https://osv.dev/vulnerability/CVE-2025-1022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1022/
Summaries are generated and may contain mistakes; the official description above is the record.
