# CVE-2025-1025: Cockpit Arbitrary File Upload

> An attacker can upload malicious files by bypassing extension filters, potentially leading to remote code execution on the server.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2025
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-wp68-xrfg-xvq4

## What is CVE-2025-1025?

CVE-2025-1025 is a high-severity vulnerability in cockpit-hq/cockpit, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package cockpit-hq/cockpit before 2.4.1 are vulnerable to Arbitrary File Upload where an attacker can use different extension to bypass the upload filter.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-1025?

2 open source packages ship an affected version, including cockpit-hq/cockpit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.4.1 |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.4.1 |

## How do I fix CVE-2025-1025?

Upgrade cockpit-hq/cockpit to 2.4.1 or later.

## Is CVE-2025-1025 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1025 exists.

Public exploit code:

- Cockpit < 2.4.1 - Arbitrary File Upload (nuclei): http/cves/2025/CVE-2025-1025.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1025 and fix it if it is affected.

What it is: CVE-2025-1025 is a high-severity vulnerability in cockpit-hq/cockpit, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1025 exists.

Affected packages and fixed versions:
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.4.1
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1025/ (Markdown: https://insights.sbomify.com/CVE-2025-1025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1025
- OSV: https://osv.dev/vulnerability/CVE-2025-1025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1025/
Summaries are generated and may contain mistakes; the official description above is the record.
