# CVE-2025-10281: Insecure URL Handling in git_clone Leading to Leaked API Key

> Attackers can leak GitHub API keys by providing malicious git URLs to BBOT's git_clone module, exposing sensitive credentials.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Oct 2025
- **Updated:** 9 Oct 2025
- **Also known as:** GHSA-63wh-p5fx-h4vc, PYSEC-2026-1216

## What is CVE-2025-10281?

CVE-2025-10281 is a medium-severity vulnerability in BLSOPS, LLC bbot, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

BBOT's git_clone module could be abused to disclose a GitHub API key to an attacker controlled server with a malicious formatted git URL.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-10281?

3 open source packages ship an affected version, including bbot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bbot` | PyPI | All versions | 2.7.0 |
| `bbot` | PyPI | All versions | 2.7.0 |
| `bbot` | PyPI | All versions | 2.7.0 |

## How do I fix CVE-2025-10281?

Upgrade bbot to 2.7.0 or later.

## Is CVE-2025-10281 being exploited?

There is no known exploitation of CVE-2025-10281 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10281 and fix it if it is affected.

What it is: CVE-2025-10281 is a medium-severity vulnerability in BLSOPS, LLC bbot, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-10281 in the wild and no public exploit code.

Affected packages and fixed versions:
- bbot (PyPI): affected all versions; fixed in 2.7.0
- bbot (PyPI): affected all versions; fixed in 2.7.0
- bbot (PyPI): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10281/ (Markdown: https://insights.sbomify.com/CVE-2025-10281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10281
- OSV: https://osv.dev/vulnerability/CVE-2025-10281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10281/
Summaries are generated and may contain mistakes; the official description above is the record.
