# CVE-2025-10282: GitLab Domain Confusion in gitlab Leaks API Key

> An attacker can leak GitLab API keys by exploiting domain confusion in BBOT's gitlab module via malicious URLs.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Oct 2025
- **Updated:** 9 Oct 2025
- **Also known as:** GHSA-p3v4-c93g-cmhw, PYSEC-2026-1217

## What is CVE-2025-10282?

CVE-2025-10282 is a medium-severity vulnerability in BLSOPS, LLC bbot, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

BBOT's gitlab module could be abused to disclose a GitLab API key to an attacker controlled server with a malicious formatted git URL.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-10282?

5 open source packages ship an affected version, including bbot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bbot` | PyPI | All versions | 2.7.2 |
| `bbot` | PyPI | All versions | 2.7.2 |
| `bbot` | PyPI | All versions | 2.7.2 |
| `bbot` | PyPI | From 2.7.0.6919rc0 | 2.7.2 |
| `bbot` | PyPI | From 2.7.0.6919rc0 | 2.7.2 |

## How do I fix CVE-2025-10282?

Upgrade bbot to 2.7.2 or later.

## Is CVE-2025-10282 being exploited?

There is no known exploitation of CVE-2025-10282 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10282 and fix it if it is affected.

What it is: CVE-2025-10282 is a medium-severity vulnerability in BLSOPS, LLC bbot, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-10282 in the wild and no public exploit code.

Affected packages and fixed versions:
- bbot (PyPI): affected all versions; fixed in 2.7.2
- bbot (PyPI): affected all versions; fixed in 2.7.2
- bbot (PyPI): affected all versions; fixed in 2.7.2
- bbot (PyPI): affected from 2.7.0.6919rc0; fixed in 2.7.2
- bbot (PyPI): affected from 2.7.0.6919rc0; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10282/ (Markdown: https://insights.sbomify.com/CVE-2025-10282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10282
- OSV: https://osv.dev/vulnerability/CVE-2025-10282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10282/
Summaries are generated and may contain mistakes; the official description above is the record.
