# CVE-2025-10363: Unauthenticated RCE via .NET Deserialization in Topal Finance Software

> Unauthenticated attackers can execute arbitrary code via unsafe .NET deserialization in Topal Finanzbuchhaltung, requiring an upgrade to the latest version.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/AU:Y`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-whm7-g778-6q8v

## What is CVE-2025-10363?

CVE-2025-10363 is a critical unsafe deserialization vulnerability in Topal Finanzbuchhaltung, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Topal Solutions AG Topal Finanzbuchhaltung on Windows allows Remote Code Execution.This issue affects at least Topal Finanzbuchhaltung: 10.1.5.20 and is fixed in version 11.2.12.00

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-10363?


## How do I fix CVE-2025-10363?

No fix has been published for CVE-2025-10363 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-10363 being exploited?

There is no known exploitation of CVE-2025-10363 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10363 and fix it if it is affected.

What it is: CVE-2025-10363 is a critical unsafe deserialization vulnerability in Topal Finanzbuchhaltung, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10363 in the wild and no public exploit code.

Affected product: Topal Finanzbuchhaltung. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10363/ (Markdown: https://insights.sbomify.com/CVE-2025-10363/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10363
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10363
- OSV: https://osv.dev/vulnerability/CVE-2025-10363

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10363/
Summaries are generated and may contain mistakes; the official description above is the record.
