# CVE-2025-10492: Jaspersoft Library Deserialisation Vulnerability

> Attackers can execute arbitrary code remotely by exploiting improper deserialization in the Jaspersoft reporting library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2025
- **Updated:** 10 Feb 2026
- **Also known as:** CLSA-2026-1774570930, CLSA-2026-1777941832, CLSA-2026-1778460289, GHSA-7c3f-cg9x-f3gr, UBUNTU-CVE-2025-10492

## What is CVE-2025-10492?

CVE-2025-10492 is a high-severity unsafe deserialization vulnerability in Jaspersoft JasperReports IO At-Scale, published on 16 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Java deserialisation vulnerability has been discovered in Jaspersoft Library. Improper handling of externally supplied data may allow attackers to execute arbitrary code remotely on systems that use the affected library

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-10492?

2 open source packages ship an affected version, including net.sf.jasperreports:jasperreports. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.sf.jasperreports:jasperreports` | Maven | All versions | 7.0.4 |
| `net.sf.jasperreports:jasperreports` | Maven | All versions | 7.0.4 |

Products: Cloud Jasperreports Io, Cloud Jasperreports Library, Cloud Jasperreports Server, Cloud Jasperreports Studio, Cloud Jasperreports Web Studio.

## How do I fix CVE-2025-10492?

Upgrade net.sf.jasperreports:jasperreports to 7.0.4 or later.

## Is CVE-2025-10492 being exploited?

There is no known exploitation of CVE-2025-10492 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10492 and fix it if it is affected.

What it is: CVE-2025-10492 is a high-severity unsafe deserialization vulnerability in Jaspersoft JasperReports IO At-Scale, published on 16 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10492 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.sf.jasperreports:jasperreports (Maven): affected all versions; fixed in 7.0.4
- net.sf.jasperreports:jasperreports (Maven): affected all versions; fixed in 7.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10492/ (Markdown: https://insights.sbomify.com/CVE-2025-10492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10492
- OSV: https://osv.dev/vulnerability/CVE-2025-10492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10492/
Summaries are generated and may contain mistakes; the official description above is the record.
