CVE-2025-10493 Chained Quiz <= 1.3.5 - Unauthenticated Insecure Direct Object Reference via Cookie

Medium 5.3 Published Updated

Unauthenticated attackers can modify other users' quiz answers and scores by manipulating the completion ID cookie in the Chained Quiz WordPress plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-10493?

CVE-2025-10493 is a medium-severity missing authorization vulnerability in prasunsen Chained Quiz, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Chained Quiz plugin for WordPress is vulnerable to Insecure Direct Object Reference in version 1.3.4 and below via the quiz submission and completion mechanisms due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to hijack and modify other users' quiz attempts by manipulating the chained_completion_id cookie value, allowing them to alter quiz answers, scores, and results of any user. The vulnerability was partially patched in versions 1.3.4 and 1.3.5.

Weakness: CWE-639

Which versions are affected by CVE-2025-10493?

How do I fix CVE-2025-10493?

No fix has been published for CVE-2025-10493 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-10493 being exploited?

There is no known exploitation of CVE-2025-10493 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as GHSA-5v4m-g3m7-229m.

Is CVE-2025-10493 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free