# CVE-2025-10493: Chained Quiz <= 1.3.5 - Unauthenticated Insecure Direct Object Reference via Cookie

> Unauthenticated attackers can modify other users' quiz answers and scores by manipulating the completion ID cookie in the Chained Quiz WordPress plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Sep 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-5v4m-g3m7-229m

## What is CVE-2025-10493?

CVE-2025-10493 is a medium-severity missing authorization vulnerability in prasunsen Chained Quiz, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Chained Quiz plugin for WordPress is vulnerable to Insecure Direct Object Reference in version 1.3.4 and below via the quiz submission and completion mechanisms due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to hijack and modify other users' quiz attempts by manipulating the chained_completion_id cookie value, allowing them to alter quiz answers, scores, and results of any user. The vulnerability was partially patched in versions 1.3.4 and 1.3.5.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-10493?


## How do I fix CVE-2025-10493?

No fix has been published for CVE-2025-10493 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-10493 being exploited?

There is no known exploitation of CVE-2025-10493 in the wild and no public exploit code.

Public exploit code:

- Chained Quiz  1.3.5 - Unauthenticated Insecure Direct Object Reference via Cookie (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10493 and fix it if it is affected.

What it is: CVE-2025-10493 is a medium-severity missing authorization vulnerability in prasunsen Chained Quiz, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10493 in the wild and no public exploit code.

Affected product: prasunsen Chained Quiz. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10493/ (Markdown: https://insights.sbomify.com/CVE-2025-10493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10493
- OSV: https://osv.dev/vulnerability/CVE-2025-10493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10493/
Summaries are generated and may contain mistakes; the official description above is the record.
