CVE-2025-10543 Eclipse Paho Go MQTT may incorrectly encode strings if length exceeds 65535 bytes
An integer overflow in the Eclipse Paho Go MQTT library allows attackers to cause data leakage or packet corruption by sending oversized UTF-8 strings.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-10543?
CVE-2025-10543 is a medium-severity vulnerability in Eclipse Foundation paho.mqtt.golang (Go MQTT v3.1 library), published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Eclipse Paho Go MQTT v3.1 library (paho.mqtt.golang) versions <=1.5.0 UTF-8 encoded strings, passed into the library, may be incorrectly encoded if their length exceeds 65535 bytes. This may lead to unexpected content in packets sent to the server (for example, part of an MQTT topic may leak into the message body in a PUBLISH packet).
The issue arises because the length of the data passed in was converted from an int64/int32 (depending upon CPU) to an int16 without checks for overflows. The int16 length was then written, followed by the data (e.g. topic). This meant that when the data (e.g. topic) was over 65535 bytes then the amount of data written exceeds what the length field indicates. This could lead to a corrupt packet, or mean that the excess data leaks into another field (e.g. topic leaks into message body).
Which versions are affected by CVE-2025-10543?
3 open source packages ship an affected version, including github.com/eclipse/paho.mqtt.golang. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/eclipse/paho.mqtt.golang Go | All versions | 1.5.1 |
github.com/eclipse/paho.mqtt.golang Go | All versions | 1.5.1 |
github.com/eclipse/paho.mqtt.golang Go | All versions | 1.5.1 |
Products include Eclipse Paho Mqtt.
How do I fix CVE-2025-10543?
Upgrade github.com/eclipse/paho.mqtt.golang to 1.5.1 or later.
Is CVE-2025-10543 being exploited?
There is no known exploitation of CVE-2025-10543 in the wild and no public exploit code.
Sources
Also known as AZL-71299, AZL-71311, AZL-71320, AZL-71332, CLEANSTART-2026-QA96824, GHSA-32fw-gq77-f2f2 and 10 more.