CVE-2025-10545 Guest user can add unauthorized team users to private channels

Low 3.1 Published Updated

Guest users can bypass permission checks to add unauthorized team members to private channels, exposing sensitive communications.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-10545?

CVE-2025-10545 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.5.x <= 10.5.10, 10.11.x <= 10.11.2 fail to properly validate guest user permissions when adding channel members which allows guest users to add any team members to their private channels via the `/api/v4/channels/{channel_id}/members` endpoint

Weakness: CWE-863

Which versions are affected by CVE-2025-10545?

10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.3
github.com/mattermost/mattermost-server GoFrom 10.11.010.11.3
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.11
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.11
github.com/mattermost/mattermost-server GoFrom 10.5.0+incompatible10.5.11+incompatible, 10.11.3+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
4 more packages
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250820115038-ff30b84049f0
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250820115038-ff30b84049f0
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250820115038-ff30b84049f0

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-10545?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.3, 10.5.11, 10.5.11+incompatible or 10.11.3+incompatible.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-10545 being exploited?

There is no known exploitation of CVE-2025-10545 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-424h-xj87-m937, GO-2025-4030.

Is CVE-2025-10545 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free