# CVE-2025-1057: Keylime: keylime registrar dos due to incompatible database entry handling

> Incompatible database entry handling in Keylime registrar causes exceptions and denial of service for agents during registration.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Mar 2025
- **Updated:** 29 Jun 2026
- **Also known as:** GHSA-9jxq-5x44-gx23, PYSEC-2026-1488, openSUSE-SU-2025:14813-1

## What is CVE-2025-1057?

CVE-2025-1057 is a medium-severity denial of service vulnerability in Red Hat Enterprise Linux 10, published on 15 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Keylime, a remote attestation solution, where strict type checking introduced in version 7.12.0 prevents the registrar from reading database entries created by previous versions, for example, 7.11.0. Specifically, older versions store agent registration data as bytes, whereas the updated registrar expects str. This issue leads to an exception when processing agent registration requests, causing the agent to fail.

Weakness: CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2025-1057?

3 open source packages ship an affected version, including keylime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keylime` | PyPI | From 7.12.0 | 7.12.1 |
| `keylime` | PyPI | From 7.12.0 | 7.12.1 |
| `keylime` | PyPI | From 7.12.0 | 7.12.1 |
| `keylime` | openSUSE:Tumbleweed | All versions | 7.12.1-1.1 |

## How do I fix CVE-2025-1057?

Upgrade keylime to 7.12.1 or later.

## Is CVE-2025-1057 being exploited?

There is no known exploitation of CVE-2025-1057 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1057 and fix it if it is affected.

What it is: CVE-2025-1057 is a medium-severity denial of service vulnerability in Red Hat Enterprise Linux 10, published on 15 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-1057 in the wild and no public exploit code.

Affected packages and fixed versions:
- keylime (PyPI): affected from 7.12.0; fixed in 7.12.1
- keylime (PyPI): affected from 7.12.0; fixed in 7.12.1
- keylime (PyPI): affected from 7.12.0; fixed in 7.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1057/ (Markdown: https://insights.sbomify.com/CVE-2025-1057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1057
- OSV: https://osv.dev/vulnerability/CVE-2025-1057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1057/
Summaries are generated and may contain mistakes; the official description above is the record.
