CVE-2025-10619 sequa-ai sequa-mcp OAuth Server Discovery node-oauth-client-provider.ts redirectToAuthorization os command injection

Medium 5.3 Published Updated

Attackers can execute arbitrary OS commands via OAuth server discovery if non-default URLs are used, requiring an upgrade to the sequa-mcp library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-10619?

CVE-2025-10619 is a medium-severity command injection vulnerability in sequa-ai sequa-mcp, published on 17 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was detected in sequa-ai sequa-mcp up to 1.0.13. This affects the function redirectToAuthorization of the file src/helpers/node-oauth-client-provider.ts of the component OAuth Server Discovery. Performing manipulation results in os command injection. Remote exploitation of the attack is possible. The exploit is now public and may be used. Upgrading to version 1.0.14 is able to mitigate this issue. The patch is named e569815854166db5f71c2e722408f8957fb9e804. It is recommended to upgrade the affected component. The vendor explains: "We only promote that mcp server with our own URLs that have a valid response, but yes if someone would use it with a non sequa url, this is a valid attack vector. We have released a new version (1.0.14) that fixes this and validates that only URLs can be opened."

Weakness: CWE-78, CWE-77

Which versions are affected by CVE-2025-10619?

2 open source packages ship an affected version, including @sequa-ai/sequa-mcp.

PackageAffectedFixed in
@sequa-ai/sequa-mcp npmAll versions1.0.14
@sequa-ai/sequa-mcp npmAll versions1.0.14

How do I fix CVE-2025-10619?

Upgrade @sequa-ai/sequa-mcp to 1.0.14 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-10619 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10619 exists.

Sources

Also known as GHSA-9pw5-wx67-q964.

Is CVE-2025-10619 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free