{"answers":{"affected":"2 open source packages ship an affected version, including @sequa-ai/sequa-mcp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10619 exists.","fix":"Upgrade @sequa-ai/sequa-mcp to 1.0.14 or later.","what":"CVE-2025-10619 is a medium-severity command injection vulnerability in sequa-ai sequa-mcp, published on 17 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-10619 and fix it if it is affected.\n\nWhat it is: CVE-2025-10619 is a medium-severity command injection vulnerability in sequa-ai sequa-mcp, published on 17 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10619 exists.\n\nAffected packages and fixed versions:\n- @sequa-ai/sequa-mcp (npm): affected all versions; fixed in 1.0.14\n- @sequa-ai/sequa-mcp (npm): affected all versions; fixed in 1.0.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10619/ (Markdown: https://insights.sbomify.com/CVE-2025-10619/index.md)","id":"CVE-2025-10619","markdown":"https://insights.sbomify.com/CVE-2025-10619/index.md","name":"CVE-2025-10619","record":{"aliases":["GHSA-9pw5-wx67-q964"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"MCP server library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary OS commands via OAuth server discovery if non-default URLs are used, requiring an upgrade to the sequa-mcp library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A vulnerability was detected in sequa-ai sequa-mcp up to 1.0.13. This affects the function redirectToAuthorization of the file src/helpers/node-oauth-client-provider.ts of the component OAuth Server Discovery. Performing manipulation results in os command injection. Remote exploitation of the attack is possible. The exploit is now public and may be used. Upgrading to version 1.0.14 is able to mitigate this issue. The patch is named e569815854166db5f71c2e722408f8957fb9e804. It is recommended to upgrade the affected component. The vendor explains: \"We only promote that mcp server with our own URLs that have a valid response, but yes if someone would use it with a non sequa url, this is a valid attack vector. We have released a new version (1.0.14) that fixes this and validates that only URLs can be opened.\"","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"sequa-ai sequa-mcp OAuth Server Discovery node-oauth-client-provider.ts redirectToAuthorization os command injection","id":"CVE-2025-10619","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"itsourcecode Online Clinic Management System editp2.php sql injection","id":"CVE-2025-10620"},"packages":[{"ecosystem":"npm","fixed":["1.0.14"],"introduced":["0"],"last_affected":[],"package":"@sequa-ai/sequa-mcp","purl":null,"source":"GHSA-9pw5-wx67-q964"},{"ecosystem":"npm","fixed":["1.0.14"],"introduced":["0"],"last_affected":[],"package":"@sequa-ai/sequa-mcp","purl":"pkg:npm/%40sequa-ai/sequa-mcp","source":"GHSA-9pw5-wx67-q964"}],"prev":{"headline":"itsourcecode Online Clinic Management System transact.php sql injection","id":"CVE-2025-10618"},"products":["sequa-mcp"],"published":"2025-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-18","vendors":["sequa-ai"]},"summary":"Attackers can execute arbitrary OS commands via OAuth server discovery if non-default URLs are used, requiring an upgrade to the sequa-mcp library.","url":"https://insights.sbomify.com/CVE-2025-10619/"}