# CVE-2025-10630: Regex DoS in Grafana Zabbix Plugin

> An attacker can cause a denial of service by submitting a malicious regex query to the Grafana Zabbix plugin, exhausting CPU resources.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2025
- **Updated:** 24 Sep 2025
- **Also known as:** GHSA-g4rr-88fc-26fj, GO-2025-3976

## What is CVE-2025-10630?

CVE-2025-10630 is a medium-severity denial of service vulnerability in grafana-zabbix-plugin, published on 19 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grafana is an open-source platform for monitoring and observability. Grafana-Zabbix is a plugin for Grafana allowing to visualize monitoring data from Zabbix and create dashboards for analyzing metrics and realtime monitoring. 

Versions 5.2.1 and below contained a ReDoS vulnerability via user-supplied regex query which could causes CPU usage to max out. This vulnerability is fixed in version 6.0.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-10630?

3 open source packages ship an affected version, including github.com/alexanderzobnin/grafana-zabbix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/alexanderzobnin/grafana-zabbix` | Go | All versions | None |
| `github.com/alexanderzobnin/grafana-zabbix` | Go | All versions | 6.0.0 |
| `github.com/alexanderzobnin/grafana-zabbix` | Go | All versions | 6.0.0 |

## How do I fix CVE-2025-10630?

Upgrade github.com/alexanderzobnin/grafana-zabbix to 6.0.0 or later.

## Is CVE-2025-10630 being exploited?

There is no known exploitation of CVE-2025-10630 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10630 and fix it if it is affected.

What it is: CVE-2025-10630 is a medium-severity denial of service vulnerability in grafana-zabbix-plugin, published on 19 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10630 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/alexanderzobnin/grafana-zabbix (Go): affected all versions; no fix listed
- github.com/alexanderzobnin/grafana-zabbix (Go): affected all versions; fixed in 6.0.0
- github.com/alexanderzobnin/grafana-zabbix (Go): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10630/ (Markdown: https://insights.sbomify.com/CVE-2025-10630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10630
- OSV: https://osv.dev/vulnerability/CVE-2025-10630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10630/
Summaries are generated and may contain mistakes; the official description above is the record.
