# CVE-2025-10678: Admin with default credentials in NetBird VPN

> Attackers can gain admin access to NetBird VPN instances installed via vendor scripts due to unchanged default ZITADEL admin credentials.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2025
- **Updated:** 20 Oct 2025
- **Also known as:** GHSA-g3j4-58mp-3x25, GO-2025-4040

## What is CVE-2025-10678?

CVE-2025-10678 is a critical vulnerability in NetBird, published on 20 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NetBird VPN when installed using vendor's provided script failed to remove or change default password of an admin account created by ZITADEL.
This issue affects instances installed using vendor's provided script. This issue may affect instances created with Docker if the default password was not changed nor the user was removed.

This issue has been fixed in version 0.57.0

Weakness: CWE-1392 (Use of Default Credentials)

## Which versions are affected by CVE-2025-10678?

3 open source packages ship an affected version, including github.com/netbirdio/netbird.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/netbirdio/netbird` | Go | All versions | 0.57.0 |
| `github.com/netbirdio/netbird` | Go | All versions | 0.57.0 |
| `github.com/netbirdio/netbird` | Go | All versions | 0.57.0 |

## How do I fix CVE-2025-10678?

Upgrade github.com/netbirdio/netbird to 0.57.0 or later.

## Is CVE-2025-10678 being exploited?

There is no known exploitation of CVE-2025-10678 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10678 and fix it if it is affected.

What it is: CVE-2025-10678 is a critical vulnerability in NetBird, published on 20 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10678 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/netbirdio/netbird (Go): affected all versions; fixed in 0.57.0
- github.com/netbirdio/netbird (Go): affected all versions; fixed in 0.57.0
- github.com/netbirdio/netbird (Go): affected all versions; fixed in 0.57.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10678/ (Markdown: https://insights.sbomify.com/CVE-2025-10678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10678
- OSV: https://osv.dev/vulnerability/CVE-2025-10678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10678/
Summaries are generated and may contain mistakes; the official description above is the record.
