CVE-2025-10858 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

Unauthenticated attackers can cause a Denial of Service by uploading crafted large JSON files, requiring GitLab administrators to upgrade.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-10858?

CVE-2025-10858 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1 that allows unauthenticated users to cause a Denial of Service (DoS) condition while uploading specifically crafted large JSON files.

Weakness: CWE-770

Which versions are affected by CVE-2025-10858?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions18.2.7, 18.3.3, 18.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-10858?

Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-10858 being exploited?

There is no known exploitation of CVE-2025-10858 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-10858, GHSA-g349-hgx7-9cj9.

Is CVE-2025-10858 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free