{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-10861 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-10861 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-10861 is a high-severity server-side request forgery vulnerability in roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers, published on 24 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-10861 and fix it if it is affected.\n\nWhat it is: CVE-2025-10861 is a high-severity server-side request forgery vulnerability in roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers, published on 24 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-10861 in the wild and no public exploit code.\n\nAffected product: roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10861/ (Markdown: https://insights.sbomify.com/CVE-2025-10861/index.md)","id":"CVE-2025-10861","markdown":"https://insights.sbomify.com/CVE-2025-10861/index.md","name":"CVE-2025-10861","record":{"aliases":["GHSA-9pjw-6vrh-2rph"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can exploit insufficient URL validation to perform Server-Side Request Forgery, accessing internal services and modifying data.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.1.4. This is due to insufficient validation on the URLs supplied via the URL parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services, as well as conduct network reconnaissance. The vulnerability was partially patched in version 2.1.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Server-side request forgery in Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers","id":"CVE-2025-10861","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"SQL injection in Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers","id":"CVE-2025-10862"},"packages":[],"prev":{"headline":"Data stored in cookies for non-HTML content while browsing Incognito could be viewed after closing private tabs","id":"CVE-2025-10859"},"products":["Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers"],"published":"2025-10-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["roxnor"]},"summary":"Unauthenticated attackers can exploit insufficient URL validation to perform Server-Side Request Forgery, accessing internal services and modifying data.","url":"https://insights.sbomify.com/CVE-2025-10861/"}