# CVE-2025-10861: Server-side request forgery in Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers

> Unauthenticated attackers can exploit insufficient URL validation to perform Server-Side Request Forgery, accessing internal services and modifying data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Oct 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-9pjw-6vrh-2rph

## What is CVE-2025-10861?

CVE-2025-10861 is a high-severity server-side request forgery vulnerability in roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers, published on 24 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.1.4. This is due to insufficient validation on the URLs supplied via the URL parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services, as well as conduct network reconnaissance. The vulnerability was partially patched in version 2.1.4.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-10861?


## How do I fix CVE-2025-10861?

No fix has been published for CVE-2025-10861 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-10861 being exploited?

There is no known exploitation of CVE-2025-10861 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10861 and fix it if it is affected.

What it is: CVE-2025-10861 is a high-severity server-side request forgery vulnerability in roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers, published on 24 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10861 in the wild and no public exploit code.

Affected product: roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10861/ (Markdown: https://insights.sbomify.com/CVE-2025-10861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10861
- OSV: https://osv.dev/vulnerability/CVE-2025-10861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10861/
Summaries are generated and may contain mistakes; the official description above is the record.
