CVE-2025-10868 Business Logic Errors in GitLab

Low 3.5 Published Updated

Attackers can cause performance degradation and potential denial of service by submitting large inputs to specific string conversion methods in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-10868?

CVE-2025-10868 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 26 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.4 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1 where certain string conversion methods exhibit performance degradation with large inputs.

Weakness: CWE-840

Which versions are affected by CVE-2025-10868?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.4.018.2.7, 18.3.3, 18.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-10868?

Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-10868 being exploited?

There is no known exploitation of CVE-2025-10868 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-10868, GHSA-vrvm-qc4x-35pw.

Is CVE-2025-10868 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free