CVE-2025-10871 Missing Authorization in GitLab

Low 3.8 Published Updated

Project Maintainers can assign custom roles with permissions exceeding their own, allowing them to elevate their privileges within GitLab Enterprise Edition.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-10871?

CVE-2025-10871 is a low-severity vulnerability in Gitlab Gitlab, published on 26 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions from 16.6 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1. Project Maintainers can exploit a vulnerability where they can assign custom roles to users with permissions exceeding their own, effectively granting themselves elevated privileges.

Weakness: CWE-862

Which versions are affected by CVE-2025-10871?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.6.018.2.7, 18.3.3, 18.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-10871?

Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.

Is CVE-2025-10871 being exploited?

There is no known exploitation of CVE-2025-10871 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-10871, GHSA-9396-6m54-w269.

Is CVE-2025-10871 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free