# CVE-2025-10871: Missing Authorization in GitLab

> Project Maintainers can assign custom roles with permissions exceeding their own, allowing them to elevate their privileges within GitLab Enterprise Edition.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-gitlab-2025-10871, GHSA-9396-6m54-w269

## What is CVE-2025-10871?

CVE-2025-10871 is a low-severity vulnerability in Gitlab Gitlab, published on 26 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue has been discovered in GitLab EE affecting all versions from 16.6 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1. Project Maintainers can exploit a vulnerability where they can assign custom roles to users with permissions exceeding their own, effectively granting themselves elevated privileges.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-10871?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.6.0 | 18.2.7, 18.3.3, 18.4.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-10871?

Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.

## Is CVE-2025-10871 being exploited?

There is no known exploitation of CVE-2025-10871 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10871 and fix it if it is affected.

What it is: CVE-2025-10871 is a low-severity vulnerability in Gitlab Gitlab, published on 26 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10871 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.6.0; fixed in 18.2.7, 18.3.3, 18.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10871/ (Markdown: https://insights.sbomify.com/CVE-2025-10871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10871
- OSV: https://osv.dev/vulnerability/CVE-2025-10871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10871/
Summaries are generated and may contain mistakes; the official description above is the record.
