{"answers":{"affected":"2 open source packages ship an affected version, including drupal/json_field. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-10926 in the wild and no public exploit code.","fix":"Upgrade drupal/json_field to 1.5 or later.","what":"CVE-2025-10926 is a medium-severity cross-site scripting vulnerability in Drupal JSON Field, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-10926 and fix it if it is affected.\n\nWhat it is: CVE-2025-10926 is a medium-severity cross-site scripting vulnerability in Drupal JSON Field, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-10926 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/json_field (Packagist): affected all versions; fixed in 1.5\n- drupal/json_field (Packagist): affected all versions; fixed in 1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10926/ (Markdown: https://insights.sbomify.com/CVE-2025-10926/index.md)","id":"CVE-2025-10926","markdown":"https://insights.sbomify.com/CVE-2025-10926/index.md","name":"CVE-2025-10926","record":{"aliases":["DRUPAL-CONTRIB-2025-106","GHSA-m3f2-xjgc-2wp2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal JSON Field","requires_auth":"none","summary":"Attackers can inject malicious scripts via the JSON Field module, potentially leading to session hijacking or code execution in Drupal sites.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"json_field","vendor":"json_field_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal JSON Field allows Cross-Site Scripting (XSS).This issue affects JSON Field: from 0.0.0 before 1.5.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JSON Field - Critical - Cross Site Scripting - SA-CONTRIB-2025-106","id":"CVE-2025-10926","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Plausible tracking - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-107","id":"CVE-2025-10927"},"packages":[{"ecosystem":"Packagist","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"drupal/json_field","purl":null,"source":"GHSA-m3f2-xjgc-2wp2"},{"ecosystem":"Packagist","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"drupal/json_field","purl":"pkg:composer/drupal/json_field","source":"GHSA-m3f2-xjgc-2wp2"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"drupal/json_field","purl":"pkg:composer/drupal/json_field?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-106"}],"prev":{"headline":"GIMP ILBM File Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability","id":"CVE-2025-10925"},"products":["JSON Field"],"published":"2025-10-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-30","vendors":["Drupal"]},"summary":"Attackers can inject malicious scripts via the JSON Field module, potentially leading to session hijacking or code execution in Drupal sites.","url":"https://insights.sbomify.com/CVE-2025-10926/"}