# CVE-2025-10927: Plausible tracking - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-107

> An attacker can inject malicious scripts into web pages via the Plausible tracking module, potentially compromising user sessions or data.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** DRUPAL-CONTRIB-2025-107, GHSA-pr6m-qwrr-mrw9

## What is CVE-2025-10927?

CVE-2025-10927 is a medium-severity cross-site scripting vulnerability in Drupal Plausible tracking, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Plausible tracking allows Cross-Site Scripting (XSS).This issue affects Plausible tracking: from 0.0.0 before 1.0.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-10927?

2 open source packages ship an affected version, including drupal/plausible_tracking. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/plausible_tracking` | Packagist | All versions | 1.0.2 |
| `drupal/plausible_tracking` | Packagist | All versions | 1.0.2 |
| `drupal/plausible_tracking` | Packagist:https://packages.drupal.org/8 | All versions | 1.0.2 |

Products: Plausible Tracking Project Plausible Tracking.

## How do I fix CVE-2025-10927?

Upgrade drupal/plausible_tracking to 1.0.2 or later.

## Is CVE-2025-10927 being exploited?

There is no known exploitation of CVE-2025-10927 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10927 and fix it if it is affected.

What it is: CVE-2025-10927 is a medium-severity cross-site scripting vulnerability in Drupal Plausible tracking, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-10927 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/plausible_tracking (Packagist): affected all versions; fixed in 1.0.2
- drupal/plausible_tracking (Packagist): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10927/ (Markdown: https://insights.sbomify.com/CVE-2025-10927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10927
- OSV: https://osv.dev/vulnerability/CVE-2025-10927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10927/
Summaries are generated and may contain mistakes; the official description above is the record.
