{"answers":{"affected":"2 open source packages ship an affected version, including drupal/access_code. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-10928 in the wild and no public exploit code.","fix":"Upgrade drupal/access_code to 2.0.5 or later.","what":"CVE-2025-10928 is a medium-severity authentication bypass vulnerability in Drupal Access code, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-10928 and fix it if it is affected.\n\nWhat it is: CVE-2025-10928 is a medium-severity authentication bypass vulnerability in Drupal Access code, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-10928 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/access_code (Packagist): affected all versions; fixed in 2.0.5\n- drupal/access_code (Packagist): affected all versions; fixed in 2.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10928/ (Markdown: https://insights.sbomify.com/CVE-2025-10928/index.md)","id":"CVE-2025-10928","markdown":"https://insights.sbomify.com/CVE-2025-10928/index.md","name":"CVE-2025-10928","record":{"aliases":["DRUPAL-CONTRIB-2025-108","GHSA-27mc-9399-r9mx"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Access code module","requires_auth":"low_privilege","summary":"Attackers can bypass authentication restrictions to perform brute force attacks on the Drupal Access code module.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"access_code","vendor":"access_code_project"}],"cvss":{"score":6.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"}],"description":"Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.5.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-108","id":"CVE-2025-10928","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Reverse Proxy Header - Less critical - Access bypass - SA-CONTRIB-2025-111","id":"CVE-2025-10929"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"drupal/access_code","purl":null,"source":"GHSA-27mc-9399-r9mx"},{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"drupal/access_code","purl":"pkg:composer/drupal/access_code","source":"GHSA-27mc-9399-r9mx"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"drupal/access_code","purl":"pkg:composer/drupal/access_code?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-108"}],"prev":{"headline":"Plausible tracking - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-107","id":"CVE-2025-10927"},"products":["Access code"],"published":"2025-10-29","related":[{"cvss_score":4.8,"headline":"Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-028","id":"CVE-2025-3129","kev_date_added":null,"published":"2025-04-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-30","vendors":["Drupal"]},"summary":"Attackers can bypass authentication restrictions to perform brute force attacks on the Drupal Access code module.","url":"https://insights.sbomify.com/CVE-2025-10928/"}