# CVE-2025-10928: Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-108

> Attackers can bypass authentication restrictions to perform brute force attacks on the Drupal Access code module.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** DRUPAL-CONTRIB-2025-108, GHSA-27mc-9399-r9mx

## What is CVE-2025-10928?

CVE-2025-10928 is a medium-severity authentication bypass vulnerability in Drupal Access code, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.5.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-10928?

2 open source packages ship an affected version, including drupal/access_code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/access_code` | Packagist | All versions | 2.0.5 |
| `drupal/access_code` | Packagist | All versions | 2.0.5 |
| `drupal/access_code` | Packagist:https://packages.drupal.org/8 | All versions | 2.0.5 |

Products: Access Code Project Access Code.

## How do I fix CVE-2025-10928?

Upgrade drupal/access_code to 2.0.5 or later.

## Is CVE-2025-10928 being exploited?

There is no known exploitation of CVE-2025-10928 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Access code

- [CVE-2025-3129](https://insights.sbomify.com/CVE-2025-3129/): Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-028 (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10928 and fix it if it is affected.

What it is: CVE-2025-10928 is a medium-severity authentication bypass vulnerability in Drupal Access code, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10928 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/access_code (Packagist): affected all versions; fixed in 2.0.5
- drupal/access_code (Packagist): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10928/ (Markdown: https://insights.sbomify.com/CVE-2025-10928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10928
- OSV: https://osv.dev/vulnerability/CVE-2025-10928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10928/
Summaries are generated and may contain mistakes; the official description above is the record.
