{"answers":{"affected":"2 open source packages ship an affected version, including drupal/currency. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-10930 in the wild and no public exploit code.","fix":"Upgrade drupal/currency to 3.5.0 or later.","what":"CVE-2025-10930 is a medium-severity vulnerability in Drupal Currency, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-10930 and fix it if it is affected.\n\nWhat it is: CVE-2025-10930 is a medium-severity vulnerability in Drupal Currency, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-10930 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/currency (Packagist): affected all versions; fixed in 3.5.0\n- drupal/currency (Packagist): affected all versions; fixed in 3.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10930/ (Markdown: https://insights.sbomify.com/CVE-2025-10930/index.md)","id":"CVE-2025-10930","markdown":"https://insights.sbomify.com/CVE-2025-10930/index.md","name":"CVE-2025-10930","record":{"aliases":["DRUPAL-CONTRIB-2025-110","GHSA-27fv-rpgj-4c6m"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Currency module","requires_auth":"none","summary":"Attackers can trick authenticated users into performing unintended actions in the Drupal Currency module, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"currency","vendor":"2bits"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery.This issue affects Currency: from 0.0.0 before 3.5.0.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Currency - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-110","id":"CVE-2025-10930","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Umami Analytics - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-109","id":"CVE-2025-10931"},"packages":[{"ecosystem":"Packagist","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"drupal/currency","purl":null,"source":"GHSA-27fv-rpgj-4c6m"},{"ecosystem":"Packagist","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"drupal/currency","purl":"pkg:composer/drupal/currency","source":"GHSA-27fv-rpgj-4c6m"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"drupal/currency","purl":"pkg:composer/drupal/currency?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-110"}],"prev":{"headline":"Reverse Proxy Header - Less critical - Access bypass - SA-CONTRIB-2025-111","id":"CVE-2025-10929"},"products":["Currency"],"published":"2025-10-29","related":[{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2010-1074","kev_date_added":null,"published":"2010-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-30","vendors":["Drupal"]},"summary":"Attackers can trick authenticated users into performing unintended actions in the Drupal Currency module, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2025-10930/"}