# CVE-2025-10930: Currency - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-110

> Attackers can trick authenticated users into performing unintended actions in the Drupal Currency module, requiring an upgrade to mitigate.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** DRUPAL-CONTRIB-2025-110, GHSA-27fv-rpgj-4c6m

## What is CVE-2025-10930?

CVE-2025-10930 is a medium-severity vulnerability in Drupal Currency, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Currency allows Cross Site Request Forgery.This issue affects Currency: from 0.0.0 before 3.5.0.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-10930?

2 open source packages ship an affected version, including drupal/currency. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/currency` | Packagist | All versions | 3.5.0 |
| `drupal/currency` | Packagist | All versions | 3.5.0 |
| `drupal/currency` | Packagist:https://packages.drupal.org/8 | All versions | 3.5.0 |

Products: 2bits Currency.

## How do I fix CVE-2025-10930?

Upgrade drupal/currency to 3.5.0 or later.

## Is CVE-2025-10930 being exploited?

There is no known exploitation of CVE-2025-10930 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Currency

- [CVE-2010-1074](https://insights.sbomify.com/CVE-2010-1074/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10930 and fix it if it is affected.

What it is: CVE-2025-10930 is a medium-severity vulnerability in Drupal Currency, published on 29 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10930 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/currency (Packagist): affected all versions; fixed in 3.5.0
- drupal/currency (Packagist): affected all versions; fixed in 3.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10930/ (Markdown: https://insights.sbomify.com/CVE-2025-10930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10930
- OSV: https://osv.dev/vulnerability/CVE-2025-10930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10930/
Summaries are generated and may contain mistakes; the official description above is the record.
