{"answers":{"affected":"2 open source packages ship an affected version, including drupal/umami_analytics. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-10931 in the wild and no public exploit code.","fix":"Upgrade drupal/umami_analytics to 1.0.1 or later.","what":"CVE-2025-10931 is a low-severity cross-site scripting vulnerability in Drupal Umami Analytics, published on 29 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-10931 and fix it if it is affected.\n\nWhat it is: CVE-2025-10931 is a low-severity cross-site scripting vulnerability in Drupal Umami Analytics, published on 29 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-10931 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/umami_analytics (Packagist): affected all versions; fixed in 1.0.1\n- drupal/umami_analytics (Packagist): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10931/ (Markdown: https://insights.sbomify.com/CVE-2025-10931/index.md)","id":"CVE-2025-10931","markdown":"https://insights.sbomify.com/CVE-2025-10931/index.md","name":"CVE-2025-10931","record":{"aliases":["DRUPAL-CONTRIB-2025-109","GHSA-jxp8-4jw5-5xjc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal analytics plugin","requires_auth":"high_privilege","summary":"An attacker can inject malicious scripts into the Umami Analytics Drupal module, potentially compromising user sessions or site integrity.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"umami_analytics","vendor":"umami"}],"cvss":{"score":3.8,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Umami Analytics allows Cross-Site Scripting (XSS).This issue affects Umami Analytics: from 0.0.0 before 1.0.1.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Umami Analytics - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-109","id":"CVE-2025-10931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"AS2 module allows uncontrolled file uploads","id":"CVE-2025-10932"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"drupal/umami_analytics","purl":null,"source":"GHSA-jxp8-4jw5-5xjc"},{"ecosystem":"Packagist","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"drupal/umami_analytics","purl":"pkg:composer/drupal/umami_analytics","source":"GHSA-jxp8-4jw5-5xjc"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"drupal/umami_analytics","purl":"pkg:composer/drupal/umami_analytics?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-109"}],"prev":{"headline":"Currency - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-110","id":"CVE-2025-10930"},"products":["Umami Analytics"],"published":"2025-10-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-30","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into the Umami Analytics Drupal module, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2025-10931/"}