# CVE-2025-10931: Umami Analytics - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-109

> An attacker can inject malicious scripts into the Umami Analytics Drupal module, potentially compromising user sessions or site integrity.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2025
- **Updated:** 30 Oct 2025
- **Also known as:** DRUPAL-CONTRIB-2025-109, GHSA-jxp8-4jw5-5xjc

## What is CVE-2025-10931?

CVE-2025-10931 is a low-severity cross-site scripting vulnerability in Drupal Umami Analytics, published on 29 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Umami Analytics allows Cross-Site Scripting (XSS).This issue affects Umami Analytics: from 0.0.0 before 1.0.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-10931?

2 open source packages ship an affected version, including drupal/umami_analytics. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/umami_analytics` | Packagist | All versions | 1.0.1 |
| `drupal/umami_analytics` | Packagist | All versions | 1.0.1 |
| `drupal/umami_analytics` | Packagist:https://packages.drupal.org/8 | All versions | 1.0.1 |

Products: Umami Umami Analytics.

## How do I fix CVE-2025-10931?

Upgrade drupal/umami_analytics to 1.0.1 or later.

## Is CVE-2025-10931 being exploited?

There is no known exploitation of CVE-2025-10931 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10931 and fix it if it is affected.

What it is: CVE-2025-10931 is a low-severity cross-site scripting vulnerability in Drupal Umami Analytics, published on 29 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-10931 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/umami_analytics (Packagist): affected all versions; fixed in 1.0.1
- drupal/umami_analytics (Packagist): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10931/ (Markdown: https://insights.sbomify.com/CVE-2025-10931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10931
- OSV: https://osv.dev/vulnerability/CVE-2025-10931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10931/
Summaries are generated and may contain mistakes; the official description above is the record.
