# CVE-2025-10947: Sistemas Pleno Gestão de Locação CPF validarCpf authorization

> Remote attackers can bypass authorization checks in the CPF validation API endpoint, potentially accessing restricted functionality without proper permissions.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2025
- **Updated:** 25 Mar 2026
- **Also known as:** GHSA-mj23-mw6g-p34x

## What is CVE-2025-10947?

CVE-2025-10947 is a medium-severity authentication bypass vulnerability in Sistemas Pleno Gestão de Locação, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw has been found in Sistemas Pleno Gestão de Locação up to 2025.7.x. The impacted element is an unknown function of the file /api/areacliente/pessoa/validarCpf of the component CPF Handler. Executing a manipulation of the argument pes_cpf can lead to authorization bypass. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 2025.8.0 is sufficient to resolve this issue. It is advisable to upgrade the affected component.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-10947?


## How do I fix CVE-2025-10947?

No fix has been published for CVE-2025-10947 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-10947 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10947 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10947 and fix it if it is affected.

What it is: CVE-2025-10947 is a medium-severity authentication bypass vulnerability in Sistemas Pleno Gestão de Locação, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10947 exists.

Affected product: Sistemas Pleno Gestão de Locação. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10947/ (Markdown: https://insights.sbomify.com/CVE-2025-10947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10947
- OSV: https://osv.dev/vulnerability/CVE-2025-10947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10947/
Summaries are generated and may contain mistakes; the official description above is the record.
