{"answers":{"affected":"3 open source packages ship an affected version, including github.com/nyaruka/phonenumbers. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10954 exists.","fix":"Upgrade github.com/nyaruka/phonenumbers to 1.2.2 or later.","what":"CVE-2025-10954 is a medium-severity denial of service vulnerability in github.com/nyaruka/phonenumbers, published on 27 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-10954 and fix it if it is affected.\n\nWhat it is: CVE-2025-10954 is a medium-severity denial of service vulnerability in github.com/nyaruka/phonenumbers, published on 27 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10954 exists.\n\nAffected packages and fixed versions:\n- github.com/nyaruka/phonenumbers (Go): affected all versions; fixed in 1.2.2\n- github.com/nyaruka/phonenumbers (Go): affected all versions; fixed in 1.2.2\n- github.com/nyaruka/phonenumbers (Go): affected all versions; fixed in 1.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-10954/ (Markdown: https://insights.sbomify.com/CVE-2025-10954/index.md)","id":"CVE-2025-10954","markdown":"https://insights.sbomify.com/CVE-2025-10954/index.md","name":"CVE-2025-10954","record":{"aliases":["GHSA-fmjh-f678-cv3x","GO-2025-3987","MINI-23mh-x894-wr46","MINI-76qj-4j8r-cxmj","MINI-8p9m-j8jf-3m62","MINI-f88c-7hj2-wvv6","MINI-gjrv-cmxx-fxjj","MINI-hqcg-28g3-mx89","MINI-q9jh-c5w7-5jwg","MINI-x3m2-86pj-44r9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go phone number library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing crafted input to the Parse function, triggering a runtime panic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"phonenumbers","vendor":"textit"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-1286","name":"Improper Validation of Syntactic Correctness of Input"}],"description":"Versions of the package github.com/nyaruka/phonenumbers before 1.2.2 are vulnerable to Improper Validation of Syntactic Correctness of Input in the phonenumbers.Parse() function. An attacker can cause a panic by providing crafted input causing a \"runtime error: slice bounds out of range\".","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"github.com/nyaruka/phonenumbers Vulnerable to Improper Validation of Syntactic Correctness of Input","id":"CVE-2025-10954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"HTML Injection in Netcad Software's Netigma","id":"CVE-2025-10955"},"packages":[{"ecosystem":"Go","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"github.com/nyaruka/phonenumbers","purl":null,"source":"GHSA-fmjh-f678-cv3x"},{"ecosystem":"Go","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"github.com/nyaruka/phonenumbers","purl":"pkg:golang/github.com/nyaruka/phonenumbers","source":"GHSA-fmjh-f678-cv3x"},{"ecosystem":"Go","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"github.com/nyaruka/phonenumbers","purl":"pkg:golang/github.com/nyaruka/phonenumbers","source":"GO-2025-3987"}],"prev":{"headline":"UTT 1200GW/1250GW formApMail buffer overflow","id":"CVE-2025-10953"},"products":["github.com/nyaruka/phonenumbers"],"published":"2025-09-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-29","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by providing crafted input to the Parse function, triggering a runtime panic.","url":"https://insights.sbomify.com/CVE-2025-10954/"}