# CVE-2025-10954: github.com/nyaruka/phonenumbers Vulnerable to Improper Validation of Syntactic Correctness of Input

> An attacker can cause a denial of service by providing crafted input to the Parse function, triggering a runtime panic.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2025
- **Updated:** 29 Sep 2025
- **Also known as:** GHSA-fmjh-f678-cv3x, GO-2025-3987, MINI-23mh-x894-wr46, MINI-76qj-4j8r-cxmj, MINI-8p9m-j8jf-3m62, MINI-f88c-7hj2-wvv6, MINI-gjrv-cmxx-fxjj, MINI-hqcg-28g3-mx89, MINI-q9jh-c5w7-5jwg, MINI-x3m2-86pj-44r9

## What is CVE-2025-10954?

CVE-2025-10954 is a medium-severity denial of service vulnerability in github.com/nyaruka/phonenumbers, published on 27 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package github.com/nyaruka/phonenumbers before 1.2.2 are vulnerable to Improper Validation of Syntactic Correctness of Input in the phonenumbers.Parse() function. An attacker can cause a panic by providing crafted input causing a "runtime error: slice bounds out of range".

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2025-10954?

3 open source packages ship an affected version, including github.com/nyaruka/phonenumbers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nyaruka/phonenumbers` | Go | All versions | 1.2.2 |
| `github.com/nyaruka/phonenumbers` | Go | All versions | 1.2.2 |
| `github.com/nyaruka/phonenumbers` | Go | All versions | 1.2.2 |

Products: Textit Phonenumbers.

## How do I fix CVE-2025-10954?

Upgrade github.com/nyaruka/phonenumbers to 1.2.2 or later.

## Is CVE-2025-10954 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10954 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10954 and fix it if it is affected.

What it is: CVE-2025-10954 is a medium-severity denial of service vulnerability in github.com/nyaruka/phonenumbers, published on 27 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10954 exists.

Affected packages and fixed versions:
- github.com/nyaruka/phonenumbers (Go): affected all versions; fixed in 1.2.2
- github.com/nyaruka/phonenumbers (Go): affected all versions; fixed in 1.2.2
- github.com/nyaruka/phonenumbers (Go): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10954/ (Markdown: https://insights.sbomify.com/CVE-2025-10954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10954
- OSV: https://osv.dev/vulnerability/CVE-2025-10954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10954/
Summaries are generated and may contain mistakes; the official description above is the record.
