# CVE-2025-10997: Open Babel chemkinformat.cpp CheckSpecies heap-based overflow

> A heap-based buffer overflow in Open Babel allows local attackers to execute arbitrary code or cause denial of service via crafted input.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2025
- **Updated:** 26 Sep 2025
- **Also known as:** DEBIAN-CVE-2025-10997, GHSA-8wq6-qh76-wpv9, PYSEC-2026-2778, UBUNTU-CVE-2025-10997

## What is CVE-2025-10997?

CVE-2025-10997 is a medium-severity memory corruption vulnerability in Open Babel, published on 26 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw has been found in Open Babel up to 3.1.1. Impacted is the function ChemKinFormat::CheckSpecies of the file /src/formats/chemkinformat.cpp. Executing manipulation can lead to heap-based buffer overflow. The attack can only be executed locally. The exploit has been published and may be used.

Weakness: CWE-122 (Heap-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-10997?

3 open source packages ship an affected version, including openbabel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |

Products: Openbabel Open Babel.

## How do I fix CVE-2025-10997?

Upgrade openbabel to 3.2.0 or later.

## Is CVE-2025-10997 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10997 exists.

## Other vulnerabilities in Open Babel

- [CVE-2022-41793](https://insights.sbomify.com/CVE-2022-41793/): Open Babel has out-of-bounds write in CSR PadString (title field) (critical 9.8)
- [CVE-2022-42885](https://insights.sbomify.com/CVE-2022-42885/): Open Babel has uninitialized pointer dereference in GRO residue parser (critical 9.8)
- [CVE-2022-43467](https://insights.sbomify.com/CVE-2022-43467/): Open Babel has out-of-bounds write in PQS coord_file parser (critical 9.8)
- [CVE-2022-44451](https://insights.sbomify.com/CVE-2022-44451/): Open Babel has uninitialized pointer dereference in MSI atom parser (critical 9.8)
- [CVE-2022-46280](https://insights.sbomify.com/CVE-2022-46280/): Open Babel has uninitialized pointer dereference in PQS pFormat (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-10997 and fix it if it is affected.

What it is: CVE-2025-10997 is a medium-severity memory corruption vulnerability in Open Babel, published on 26 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-10997 exists.

Affected packages and fixed versions:
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-10997/ (Markdown: https://insights.sbomify.com/CVE-2025-10997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-10997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-10997
- OSV: https://osv.dev/vulnerability/CVE-2025-10997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-10997/
Summaries are generated and may contain mistakes; the official description above is the record.
