{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11031 exists.","fix":"No fix has been published for CVE-2025-11031 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-11031 is a medium-severity path traversal vulnerability in DataTables, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-11031 and fix it if it is affected.\n\nWhat it is: CVE-2025-11031 is a medium-severity path traversal vulnerability in DataTables, published on 26 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11031 exists.\n\nAffected product: DataTables. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-11031/ (Markdown: https://insights.sbomify.com/CVE-2025-11031/index.md)","id":"CVE-2025-11031","markdown":"https://insights.sbomify.com/CVE-2025-11031/index.md","name":"CVE-2025-11031","record":{"aliases":["GHSA-h5mg-c768-q2fp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"DataTables JavaScript library","requires_auth":"none","summary":"Remote attackers can read arbitrary files via path traversal in the examples.php file, which should not be deployed in production environments.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"datatables","vendor":"sprymedia"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A flaw has been found in DataTables up to 1.10.13. The affected element is an unknown function of the file /examples/resources/examples.php. This manipulation of the argument src causes path traversal. It is possible to initiate the attack remotely. The exploit has been published and may be used. Upgrading to version 1.10.15 is sufficient to fix this issue. Patch name: 3b24f99ac4ddb7f9072076b0d07f0b1a408f177a. Upgrading the affected component is advised. This vulnerability was initially reported for code-projects Faculty Management System but appears to affect DataTables as an upstream component instead. The vendor of DataTables explains: \"I would suggest that the author upgrade to the latest versions of DataTables (actually, they shouldn't really be deploying that file to their own server at all - it is only relevant for the DataTables examples).\"","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"DataTables examples.php path traversal","id":"CVE-2025-11031","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":0,"n_references":7,"next":{"headline":"kidaze CourseSelectionSystem COUNT3s6.php sql injection","id":"CVE-2025-11032"},"packages":[],"prev":{"headline":"Tutorials-Website Employee Management System HTTP Request all-applied-leave.php improper authorization","id":"CVE-2025-11030"},"products":["DataTables"],"published":"2025-09-26","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2021-36713","kev_date_added":null,"published":"2023-03-06"},{"cvss_score":4.3,"headline":"DataTable Vulnerable to Cross-Site Scripting","id":"CVE-2015-6584","kev_date_added":null,"published":"2015-09-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-26","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files via path traversal in the examples.php file, which should not be deployed in production environments.","url":"https://insights.sbomify.com/CVE-2025-11031/"}