# CVE-2025-11143: org.eclipse.jetty:jetty-http has different parsing of invalid URIs

> Differential URI parsing in Jetty allows attackers to bypass security controls or leak implementation details in multi-component systems.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 5 Mar 2026
- **Also known as:** CLEANSTART-2026-EJ17153, CLEANSTART-2026-IM22842, CLEANSTART-2026-PC10169, CLEANSTART-2026-RP92768, CLEANSTART-2026-SN03087, CLEANSTART-2026-YV60334, CLSA-2026-1770250143, CLSA-2026-1770250144, DEBIAN-CVE-2025-11143, ECHO-27ac-9aa4-dbec, GHSA-wjpw-4j6x-6rwh, MINI-24g4-5f56-8qg6, MINI-2879-2v55-5p6x, MINI-2v4w-r82r-j9qp, MINI-2vmv-xgcx-65wf, MINI-3jmm-v27m-rrrw, MINI-3r8f-wmv2-78xx, MINI-42w2-w4g3-h99g, MINI-45q5-q8m7-q8xj, MINI-4f8c-vgmq-2m86, MINI-4m82-fchp-84j7, MINI-544h-jv5w-r8rc, MINI-549x-66hg-4ggj, MINI-5j4w-vfcc-vx46, MINI-6f7f-v3qp-v4mv, MINI-8j8f-gv3g-pgh3, MINI-8jp7-6h25-6cww, MINI-8mhp-gmxg-wh7r, MINI-c5f9-m8m6-cw88, MINI-c5gx-cph7-3xw7, MINI-cfwh-vq93-cvwc, MINI-chq7-w78x-4j22, MINI-cxmw-hcch-chm5, MINI-fvvr-9prr-c5hp, MINI-gwc8-qxpq-h4wc, MINI-h3ch-5q5j-r6m8, MINI-hc4w-fmxc-8hrf, MINI-hqq4-mpxq-w72h, MINI-j55q-v4x8-mfj8, MINI-j87f-f6qq-8pwj, MINI-jx78-qx5f-qqr9, MINI-mph5-99w4-q8mq, MINI-mpwf-6p6p-5mph, MINI-mrqq-59ff-4p6x, MINI-mv47-2xm7-2ww5, MINI-p7pw-pgv8-v7gc, MINI-p98w-42c5-wwvf, MINI-pc67-9895-wf9r, MINI-pppr-hc3x-3q4g, MINI-q7rc-c6mj-865q, MINI-q98p-ghpc-942r, MINI-qxf6-3982-7q95, MINI-r3jr-72m8-2frm, MINI-rpr7-gr4m-rp28, MINI-rrff-9p3v-h2wj, MINI-rvrf-x4c3-2cgf, MINI-rx47-wwvh-x2v5, MINI-vf5c-xjhw-54qj, MINI-vmpg-94p6-h4qc, MINI-vrgm-6vjq-wm36, MINI-vvhf-jp3j-9jpf, MINI-x498-hwxf-wv6v, MINI-x4gj-qhfm-cm6w, MINI-x83v-g3pg-24x5, MINI-xc46-v74w-wmh3, MINI-xhgq-j29r-93q5, MINI-xvhv-3452-wrmr, ROOT-APP-MAVEN-CVE-2025-11143, ROOT-APP-MAVEN-GHSA-wjpw-4j6x-6rwh, SUSE-SU-2026:1461-1, UBUNTU-CVE-2025-11143, openSUSE-SU-2026:10300-1

## What is CVE-2025-11143?

CVE-2025-11143 is a low-severity vulnerability in Eclipse Jetty, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jetty URI parser has some key differences to other common parsers when evaluating invalid or unusual URIs. Differential parsing of URIs in systems using multiple components may result in security by-pass. For example a component that enforces a black list may interpret the URIs differently from one that generates a response. At the very least, differential parsing may divulge implementation details.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-11143?

10 open source packages ship an affected version, including org.eclipse.jetty:jetty-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-http` | Maven | From 10.0.0 to 10.0.26 | None |
| `org.eclipse.jetty:jetty-http` | Maven | From 10.0.0 to 10.0.26 | None |
| `org.eclipse.jetty:jetty-http` | Maven | From 11.0.0 to 11.0.26 | None |
| `org.eclipse.jetty:jetty-http` | Maven | From 11.0.0 to 11.0.26 | None |
| `org.eclipse.jetty:jetty-http` | Maven | From 12.0.0 | 12.0.31 |
| `org.eclipse.jetty:jetty-http` | Maven | From 12.0.0 | 12.0.31 |
| `org.eclipse.jetty:jetty-http` | Maven | From 12.1.0 | 12.1.5 |
| `org.eclipse.jetty:jetty-http` | Maven | From 12.1.0 | 12.1.5 |
| `org.eclipse.jetty:jetty-http` | Maven | From 9.4.0 to 9.4.58 | None |
| `org.eclipse.jetty:jetty-http` | Maven | From 9.4.0 to 9.4.58 | None |
| `jetty-minimal` | SUSE:Linux Enterprise Module for Development Tools 15 SP7 | All versions | 9.4.58-150200.3.37.1 |
| `jetty-minimal` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 9.4.58-150200.3.37.1 |
| `jetty-minimal` | openSUSE:Leap 15.6 | All versions | 9.4.58-150200.3.37.1 |
| `jetty-websocket` | openSUSE:Leap 15.6 | All versions | 9.4.58-150200.3.37.1 |
| `jetty-minimal` | openSUSE:Tumbleweed | All versions | 9.4.58-3.1 |

Products: Eclipse Jetty.

## How do I fix CVE-2025-11143?

Upgrade org.eclipse.jetty:jetty-http to a fixed version for your release line: 12.0.31 or 12.1.5.

## Is CVE-2025-11143 being exploited?

There is no known exploitation of CVE-2025-11143 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11143 and fix it if it is affected.

What it is: CVE-2025-11143 is a low-severity vulnerability in Eclipse Jetty, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-11143 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-http (Maven): affected from 10.0.0 up to 10.0.26; no fix listed
- org.eclipse.jetty:jetty-http (Maven): affected from 10.0.0 up to 10.0.26; no fix listed
- org.eclipse.jetty:jetty-http (Maven): affected from 11.0.0 up to 11.0.26; no fix listed
- org.eclipse.jetty:jetty-http (Maven): affected from 11.0.0 up to 11.0.26; no fix listed
- org.eclipse.jetty:jetty-http (Maven): affected from 12.0.0; fixed in 12.0.31
- org.eclipse.jetty:jetty-http (Maven): affected from 12.0.0; fixed in 12.0.31
- org.eclipse.jetty:jetty-http (Maven): affected from 12.1.0; fixed in 12.1.5
- org.eclipse.jetty:jetty-http (Maven): affected from 12.1.0; fixed in 12.1.5
- org.eclipse.jetty:jetty-http (Maven): affected from 9.4.0 up to 9.4.58; no fix listed
- org.eclipse.jetty:jetty-http (Maven): affected from 9.4.0 up to 9.4.58; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11143/ (Markdown: https://insights.sbomify.com/CVE-2025-11143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11143
- OSV: https://osv.dev/vulnerability/CVE-2025-11143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11143/
Summaries are generated and may contain mistakes; the official description above is the record.
