{"answers":{"affected":"3 open source packages ship an affected version, including feast.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11157 exists.","fix":"Upgrade feast to 0.54.0 or later.","what":"CVE-2025-11157 is a high-severity unsafe deserialization vulnerability in feast-dev/feast, published on 1 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-11157 and fix it if it is affected.\n\nWhat it is: CVE-2025-11157 is a high-severity unsafe deserialization vulnerability in feast-dev/feast, published on 1 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11157 exists.\n\nAffected packages and fixed versions:\n- feast (PyPI): affected all versions; fixed in 0.54.0\n- feast (PyPI): affected all versions; fixed in 0.54.0\n- feast (PyPI): affected all versions; fixed in 0.54.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-11157/ (Markdown: https://insights.sbomify.com/CVE-2025-11157/index.md)","id":"CVE-2025-11157","markdown":"https://insights.sbomify.com/CVE-2025-11157/index.md","name":"CVE-2025-11157","record":{"aliases":["GHSA-34wm-4hw7-qfjv","PYSEC-2026-1366"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Feast feature store","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code on Kubernetes worker pods by modifying YAML configuration files due to unsafe deserialization in Feast.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer job located at `feast/sdk/python/feast/infra/compute_engines/kubernetes/main.py`. The vulnerability arises from the use of `yaml.load(..., Loader=yaml.Loader)` to deserialize `/var/feast/feature_store.yaml` and `/var/feast/materialization_config.yaml`. This method allows for the instantiation of arbitrary Python objects, enabling an attacker with the ability to modify these YAML files to execute OS commands on the worker pod. This vulnerability can be exploited before the configuration is validated, potentially leading to cluster takeover, data poisoning, and supply-chain sabotage.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Arbitrary Code Execution in feast-dev/feast","id":"CVE-2025-11157","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Hitachi Vantara Pentaho Data Integration \u0026 Analytics - Missing Authorization","id":"CVE-2025-11158"},"packages":[{"ecosystem":"PyPI","fixed":["0.54.0"],"introduced":["0"],"last_affected":[],"package":"feast","purl":null,"source":"GHSA-34wm-4hw7-qfjv"},{"ecosystem":"PyPI","fixed":["0.54.0"],"introduced":["0"],"last_affected":[],"package":"feast","purl":"pkg:pypi/feast","source":"GHSA-34wm-4hw7-qfjv"},{"ecosystem":"PyPI","fixed":["0.54.0"],"introduced":["0"],"last_affected":[],"package":"feast","purl":"pkg:pypi/feast","source":"PYSEC-2026-1366"}],"prev":{"headline":"Improper Service Loading Vulnerability in Netskope Endpoint DLP Driver","id":"CVE-2025-11156"},"products":["feast-dev/feast"],"published":"2026-01-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["feast-dev"]},"summary":"Attackers can execute arbitrary code on Kubernetes worker pods by modifying YAML configuration files due to unsafe deserialization in Feast.","url":"https://insights.sbomify.com/CVE-2025-11157/"}