# CVE-2025-11157: Arbitrary Code Execution in feast-dev/feast

> Attackers can execute arbitrary code on Kubernetes worker pods by modifying YAML configuration files due to unsafe deserialization in Feast.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-34wm-4hw7-qfjv, PYSEC-2026-1366

## What is CVE-2025-11157?

CVE-2025-11157 is a high-severity unsafe deserialization vulnerability in feast-dev/feast, published on 1 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer job located at `feast/sdk/python/feast/infra/compute_engines/kubernetes/main.py`. The vulnerability arises from the use of `yaml.load(..., Loader=yaml.Loader)` to deserialize `/var/feast/feature_store.yaml` and `/var/feast/materialization_config.yaml`. This method allows for the instantiation of arbitrary Python objects, enabling an attacker with the ability to modify these YAML files to execute OS commands on the worker pod. This vulnerability can be exploited before the configuration is validated, potentially leading to cluster takeover, data poisoning, and supply-chain sabotage.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-11157?

3 open source packages ship an affected version, including feast.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `feast` | PyPI | All versions | 0.54.0 |
| `feast` | PyPI | All versions | 0.54.0 |
| `feast` | PyPI | All versions | 0.54.0 |

## How do I fix CVE-2025-11157?

Upgrade feast to 0.54.0 or later.

## Is CVE-2025-11157 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11157 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11157 and fix it if it is affected.

What it is: CVE-2025-11157 is a high-severity unsafe deserialization vulnerability in feast-dev/feast, published on 1 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-11157 exists.

Affected packages and fixed versions:
- feast (PyPI): affected all versions; fixed in 0.54.0
- feast (PyPI): affected all versions; fixed in 0.54.0
- feast (PyPI): affected all versions; fixed in 0.54.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11157/ (Markdown: https://insights.sbomify.com/CVE-2025-11157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11157
- OSV: https://osv.dev/vulnerability/CVE-2025-11157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11157/
Summaries are generated and may contain mistakes; the official description above is the record.
