CVE-2025-11224 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 7.7 Published Updated

An authenticated user can execute stored cross-site scripting via the Kubernetes proxy functionality in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-11224?

CVE-2025-11224 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 14 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.10 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that could have allowed an authenticated user to execute stored cross-site scripting through improper input validation in the Kubernetes proxy functionality.

Weakness: CWE-79

Which versions are affected by CVE-2025-11224?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.10.018.3.6, 18.4.4, 18.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-11224?

Upgrade gitlab to a fixed version for your release line: 18.3.6, 18.4.4 or 18.5.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-11224 being exploited?

There is no known exploitation of CVE-2025-11224 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-11224, GHSA-x45w-x744-4hj7, UBUNTU-CVE-2025-11224.

Is CVE-2025-11224 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free