# CVE-2025-11226: Conditional processing of logback.xml configuration file, in conjuction with Spring Framework and Janino

> Attackers with existing privileges can execute arbitrary code in Java applications using Logback, Janino, and Spring by manipulating configuration files or environment variables.

- **Severity:** High 7.0 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N/S:P/AU:N/RE:M/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 25 Jun 2026
- **Also known as:** CLEANSTART-2026-JM74413, CLEANSTART-2026-YC63582, CLSA-2025-1765930089, CLSA-2026-1784769539, CLSA-2026-1785917146, CLSA-2026-1786355016, DEBIAN-CVE-2025-11226, ECHO-4f7a-7521-ba5b, GHSA-25qh-j22f-pwp8, MINI-244g-4x74-9g8g, MINI-2w7m-55ch-j85h, MINI-436x-868w-v65w, MINI-46ch-w7q2-4ghf, MINI-4hcx-59r2-r876, MINI-53cv-fxhm-rm4g, MINI-5cxm-hmqq-qcrv, MINI-87hc-v469-5p9p, MINI-8vgf-325r-65v5, MINI-9cjh-f83p-9696, MINI-9j73-gmq7-pf66, MINI-9wc2-hq9m-3w49, MINI-cvx5-9449-3whp, MINI-h9vw-4r72-xcg6, MINI-mw36-wg87-qp73, MINI-q4pc-26xg-j5v3, MINI-q5m9-mfj7-8j2m, MINI-q9jw-92j4-7fpj, MINI-w69v-h4rc-gpmx, ROOT-APP-MAVEN-CVE-2025-11226, SUSE-SU-2025:03456-1, UBUNTU-CVE-2025-11226

## What is CVE-2025-11226?

CVE-2025-11226 is a high-severity code injection vulnerability in QOS.CH Sarl Logback-core, published on 1 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

ACE vulnerability in conditional configuration file processing  by QOS.CH logback-core up to and including version 1.5.18 in Java applications, allows an attacker to execute arbitrary code by compromising an existing logback configuration file or by injecting an environment variable before program execution.

A successful attack requires the presence of Janino library and Spring Framework to be present on the user's class path. In addition, the attacker must  have write access to a 
configuration file. Alternatively, the attacker could inject a malicious 
environment variable pointing to a malicious configuration file. In both 
cases, the attack requires existing privilege.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-11226?

4 open source packages ship an affected version, including ch.qos.logback:logback-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ch.qos.logback:logback-core` | Maven | All versions | 1.3.16 |
| `ch.qos.logback:logback-core` | Maven | All versions | 1.3.16 |
| `ch.qos.logback:logback-core` | Maven | From 1.4.0 | 1.5.19 |
| `ch.qos.logback:logback-core` | Maven | From 1.4.0 | 1.5.19 |
| `logback` | openSUSE:Leap 15.6 | All versions | 1.2.13-150200.3.13.1 |

## How do I fix CVE-2025-11226?

Upgrade ch.qos.logback:logback-core to a fixed version for your release line: 1.3.16 or 1.5.19.

## Is CVE-2025-11226 being exploited?

There is no known exploitation of CVE-2025-11226 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11226 and fix it if it is affected.

What it is: CVE-2025-11226 is a high-severity code injection vulnerability in QOS.CH Sarl Logback-core, published on 1 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-11226 in the wild and no public exploit code.

Affected packages and fixed versions:
- ch.qos.logback:logback-core (Maven): affected all versions; fixed in 1.3.16
- ch.qos.logback:logback-core (Maven): affected all versions; fixed in 1.3.16
- ch.qos.logback:logback-core (Maven): affected from 1.4.0; fixed in 1.5.19
- ch.qos.logback:logback-core (Maven): affected from 1.4.0; fixed in 1.5.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11226/ (Markdown: https://insights.sbomify.com/CVE-2025-11226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11226
- OSV: https://osv.dev/vulnerability/CVE-2025-11226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11226/
Summaries are generated and may contain mistakes; the official description above is the record.
