CVE-2025-11246 Insufficient Granularity of Access Control in GitLab

Medium 5.4 Published Updated

Authenticated users can remove runners from unrelated projects via GraphQL manipulation, requiring GitLab upgrades.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-11246?

CVE-2025-11246 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 9 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.4 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed an authenticated user with specific permissions to remove all project runners from unrelated projects by manipulating GraphQL runner associations.

Weakness: CWE-1220

Which versions are affected by CVE-2025-11246?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.4.018.5.5, 18.6.3, 18.7.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-11246?

Upgrade gitlab to a fixed version for your release line: 18.5.5, 18.6.3 or 18.7.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-11246 being exploited?

There is no known exploitation of CVE-2025-11246 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-11246, GHSA-w2j6-r4xj-rjcj, UBUNTU-CVE-2025-11246.

Is CVE-2025-11246 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free