{"answers":{"affected":"2 open source packages ship an affected version, including pdfmake. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-11362 in the wild and no public exploit code.","fix":"Upgrade pdfmake to 0.3.0-beta.17 or later.","what":"CVE-2025-11362 is a high-severity denial of service vulnerability in org.webjars.npm:pdfmake, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-11362 and fix it if it is affected.\n\nWhat it is: CVE-2025-11362 is a high-severity denial of service vulnerability in org.webjars.npm:pdfmake, published on 7 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-11362 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pdfmake (npm): affected from 0.3.0-beta.1; fixed in 0.3.0-beta.17\n- pdfmake (npm): affected from 0.3.0-beta.1; fixed in 0.3.0-beta.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-11362/ (Markdown: https://insights.sbomify.com/CVE-2025-11362/index.md)","id":"CVE-2025-11362","markdown":"https://insights.sbomify.com/CVE-2025-11362/index.md","name":"CVE-2025-11362","record":{"aliases":["GHSA-rj3r-r7hh-jxfq","MINI-4g96-v3c3-x9qj","MINI-8hx6-cvvm-6954","MINI-jchc-m95h-crj2","MINI-q4xc-hhhf-g2cw","MINI-qjm3-49rv-mh76","MINI-vfr9-3mvf-wwv8","MINI-vrh3-mc53-48c5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript PDF library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the pdfmake library by triggering resource exhaustion via crafted file embedding URLs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"pdfmake","vendor":"pdfmake"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Versions of the package pdfmake from 0.3.0-beta.1 and before 0.3.0-beta.17 are vulnerable to Allocation of Resources Without Limits or Throttling via repeatedly redirect URL in file embedding. An attacker can cause the application to crash or become unresponsive by providing crafted input that triggers this condition.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pdfmake is vulnerable to Throttling via repeatedly redirecting URL in file embedding","id":"CVE-2025-11362","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Royal Elementor Addons and Templates \u003c 1.7.1037 - Unauthenticated Media File Upload","id":"CVE-2025-11363"},"packages":[{"ecosystem":"npm","fixed":["0.3.0-beta.17"],"introduced":["0.3.0-beta.1"],"last_affected":[],"package":"pdfmake","purl":null,"source":"GHSA-rj3r-r7hh-jxfq"},{"ecosystem":"npm","fixed":["0.3.0-beta.17"],"introduced":["0.3.0-beta.1"],"last_affected":[],"package":"pdfmake","purl":"pkg:npm/pdfmake","source":"GHSA-rj3r-r7hh-jxfq"}],"prev":{"headline":"Essential Blocks \u003c= 5.7.1 - Authenticated (Author+) Server-Side Request Forgery","id":"CVE-2025-11361"},"products":["org.webjars.npm:pdfmake","pdfmake"],"published":"2025-10-07","related":[{"cvss_score":10,"headline":"Code injection in pdfmake","id":"CVE-2022-46161","kev_date_added":null,"published":"2022-12-06"},{"cvss_score":7.5,"headline":"pdfmake is vulnerable to server-side request forgery (SSRF)","id":"CVE-2026-26801","kev_date_added":null,"published":"2026-03-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-15","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using the pdfmake library by triggering resource exhaustion via crafted file embedding URLs.","url":"https://insights.sbomify.com/CVE-2025-11362/"}