# CVE-2025-11374: Consul's KV endpoint is vulnerable to denial of service

> Attackers can cause denial of service in Consul via incorrect Content-Length header validation in the KV endpoint.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2025
- **Updated:** 17 Apr 2026
- **Also known as:** BIT-consul-2025-11374, DEBIAN-CVE-2025-11374, GHSA-7g3r-8c6v-hfmr, GO-2025-4081, UBUNTU-CVE-2025-11374

## What is CVE-2025-11374?

CVE-2025-11374 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 28 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Consul and Consul Enterprise’s (“Consul”) key/value endpoint is vulnerable to denial of service (DoS) due to incorrect Content Length header validation. This vulnerability, CVE-2025-11374, is fixed in Consul Community Edition 1.22.0 and Consul Enterprise 1.22.0, 1.21.6, 1.20.8 and 1.18.12.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-11374?

4 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | All versions | 1.22.0 |
| `github.com/hashicorp/consul` | Go | All versions | 1.22.0 |
| `github.com/hashicorp/consul` | Go | All versions | 1.22.0 |
| `consul` | Bitnami | All versions | 1.22.0 |

Products: Hashicorp Consul.

## How do I fix CVE-2025-11374?

Upgrade github.com/hashicorp/consul to 1.22.0 or later.

## Is CVE-2025-11374 being exploited?

There is no known exploitation of CVE-2025-11374 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Consul

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11374 and fix it if it is affected.

What it is: CVE-2025-11374 is a medium-severity denial of service vulnerability in HashiCorp Consul, published on 28 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-11374 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.22.0
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.22.0
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.22.0
- consul (Bitnami): affected all versions; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11374/ (Markdown: https://insights.sbomify.com/CVE-2025-11374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11374
- OSV: https://osv.dev/vulnerability/CVE-2025-11374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11374/
Summaries are generated and may contain mistakes; the official description above is the record.
