CVE-2025-11447 Allocation of Resources Without Limits or Throttling in GitLab

High 7.5 Published Updated

An unauthenticated attacker can cause a denial of service in GitLab by sending crafted GraphQL JSON payloads, requiring an upgrade to remediate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-11447?

CVE-2025-11447 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.0 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an unauthenticated attacker to cause a denial of service condition by sending GraphQL requests with crafted JSON payloads.

Weakness: CWE-770

Which versions are affected by CVE-2025-11447?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.0.018.3.5, 18.4.3, 18.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-11447?

Upgrade gitlab to a fixed version for your release line: 18.3.5, 18.4.3 or 18.5.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-11447 being exploited?

There is no known exploitation of CVE-2025-11447 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-11447, GHSA-xgjv-46p6-hwgv, UBUNTU-CVE-2025-11447.

Is CVE-2025-11447 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free