# CVE-2025-11537: Keycloak-services: sensitive headers shown in the http access logs

> Attackers with log access can steal credentials from verbose logs, enabling user impersonation and account takeover in Keycloak.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Feb 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-YQ74765, ECHO-1ec0-58d1-cb3d, GHSA-gv3v-2cpp-3pmq, MINI-95x4-3vvw-4fwq, MINI-rmrj-h6q6-37x8

## What is CVE-2025-11537?

CVE-2025-11537 is a medium-severity vulnerability in Red Hat Build of Keycloak, published on 10 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Keycloak. When the logging format is configured to a verbose, user-supplied pattern (such as the pre-defined 'long' pattern), sensitive headers including Authorization and Cookie are disclosed to the logs in cleartext. An attacker with read access to the log files can extract these credentials (e.g., bearer tokens, session cookies) and use them to impersonate users, leading to a full account compromise.

Weakness: CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2025-11537?

2 open source packages ship an affected version, including org.keycloak:keycloak-quarkus-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-quarkus-server` | Maven | All versions | 26.5.6 |
| `org.keycloak:keycloak-quarkus-server` | Maven | All versions | 26.5.6 |

## How do I fix CVE-2025-11537?

Upgrade org.keycloak:keycloak-quarkus-server to 26.5.6 or later.

## Is CVE-2025-11537 being exploited?

There is no known exploitation of CVE-2025-11537 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11537 and fix it if it is affected.

What it is: CVE-2025-11537 is a medium-severity vulnerability in Red Hat Build of Keycloak, published on 10 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-11537 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-quarkus-server (Maven): affected all versions; fixed in 26.5.6
- org.keycloak:keycloak-quarkus-server (Maven): affected all versions; fixed in 26.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11537/ (Markdown: https://insights.sbomify.com/CVE-2025-11537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11537
- OSV: https://osv.dev/vulnerability/CVE-2025-11537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11537/
Summaries are generated and may contain mistakes; the official description above is the record.
