{"answers":{"affected":"2 open source packages ship an affected version, including Amazon.IonDotnet.","exploited":"There is no known exploitation of CVE-2025-11573 in the wild and no public exploit code.","fix":"Upgrade Amazon.IonDotnet to 1.3.2 or later.","what":"CVE-2025-11573 is a high-severity denial of service vulnerability in Amazon.IonDotnet, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-11573 and fix it if it is affected.\n\nWhat it is: CVE-2025-11573 is a high-severity denial of service vulnerability in Amazon.IonDotnet, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-11573 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Amazon.IonDotnet (NuGet): affected all versions; fixed in 1.3.2\n- Amazon.IonDotnet (NuGet): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-11573/ (Markdown: https://insights.sbomify.com/CVE-2025-11573/index.md)","id":"CVE-2025-11573","markdown":"https://insights.sbomify.com/CVE-2025-11573/index.md","name":"CVE-2025-11573","record":{"aliases":["GHSA-q5r6-9qwq-g2wj"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Amazon Ion .NET library","requires_auth":"none","summary":"An attacker can cause a denial of service via infinite loop using crafted text input in the deprecated Amazon.IonDotnet library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1286","name":"Improper Validation of Syntactic Correctness of Input"}],"description":"An infinite loop issue in Amazon.IonDotnet library versions \u003cv1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input.\n\nTo mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecated and will not receive further updates.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service issue in Amazon.IonDotnet","id":"CVE-2025-11573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"MongoDB Atlas SQL ODBC driver installation via MSI may leave ACLs unset on custom installation directories","id":"CVE-2025-11575"},"packages":[{"ecosystem":"NuGet","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"Amazon.IonDotnet","purl":null,"source":"GHSA-q5r6-9qwq-g2wj"},{"ecosystem":"NuGet","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"Amazon.IonDotnet","purl":"pkg:nuget/Amazon.IonDotnet","source":"GHSA-q5r6-9qwq-g2wj"}],"prev":{"headline":"Command Execution vulnerability in Simplicity Installer","id":"CVE-2025-11571"},"products":["Amazon.IonDotnet"],"published":"2025-10-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-09","vendors":["Amazon"]},"summary":"An attacker can cause a denial of service via infinite loop using crafted text input in the deprecated Amazon.IonDotnet library.","url":"https://insights.sbomify.com/CVE-2025-11573/"}