# CVE-2025-11573: Denial of Service issue in Amazon.IonDotnet

> An attacker can cause a denial of service via infinite loop using crafted text input in the deprecated Amazon.IonDotnet library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2025
- **Updated:** 9 Oct 2025
- **Also known as:** GHSA-q5r6-9qwq-g2wj

## What is CVE-2025-11573?

CVE-2025-11573 is a high-severity denial of service vulnerability in Amazon.IonDotnet, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input.

To mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecated and will not receive further updates.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2025-11573?

2 open source packages ship an affected version, including Amazon.IonDotnet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Amazon.IonDotnet` | NuGet | All versions | 1.3.2 |
| `Amazon.IonDotnet` | NuGet | All versions | 1.3.2 |

## How do I fix CVE-2025-11573?

Upgrade Amazon.IonDotnet to 1.3.2 or later.

## Is CVE-2025-11573 being exploited?

There is no known exploitation of CVE-2025-11573 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11573 and fix it if it is affected.

What it is: CVE-2025-11573 is a high-severity denial of service vulnerability in Amazon.IonDotnet, published on 9 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-11573 in the wild and no public exploit code.

Affected packages and fixed versions:
- Amazon.IonDotnet (NuGet): affected all versions; fixed in 1.3.2
- Amazon.IonDotnet (NuGet): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11573/ (Markdown: https://insights.sbomify.com/CVE-2025-11573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11573
- OSV: https://osv.dev/vulnerability/CVE-2025-11573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11573/
Summaries are generated and may contain mistakes; the official description above is the record.
