CVE-2025-11621 Vault AWS auth method bypass due to AWS client cache
Attackers can bypass AWS authentication in HashiCorp Vault if bound_principal_iam roles are identical across accounts or use wildcards.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-11621?
CVE-2025-11621 is a high-severity authentication bypass vulnerability in Hashicorp Vault, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Vault and Vault Enterprise’s (“Vault”) AWS Auth method may be susceptible to authentication bypass if the role of the configured bound_principal_iam is the same across AWS accounts, or uses a wildcard. This vulnerability, CVE-2025-11621, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.21.0, 1.20.5, 1.19.11, and 1.16.27
Weakness: CWE-288
Which versions are affected by CVE-2025-11621?
4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/vault Go | From 0.6.0 | 1.21.0 |
github.com/hashicorp/vault Go | From 0.6.0 | 1.21.0 |
github.com/hashicorp/vault Go | From 0.6.0 | 1.21.0 |
vault Bitnami | From 0.6.0 | 1.21.0 |
Products include Hashicorp Vault.
How do I fix CVE-2025-11621?
Upgrade github.com/hashicorp/vault to 1.21.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-11621 being exploited?
There is no known exploitation of CVE-2025-11621 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-vault-2025-11621, GHSA-9g4h-h484-3578, GO-2025-4070, MINI-w34j-hg35-wmg4.