# CVE-2025-11621: Vault AWS auth method bypass due to AWS client cache

> Attackers can bypass AWS authentication in HashiCorp Vault if bound_principal_iam roles are identical across accounts or use wildcards.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-vault-2025-11621, GHSA-9g4h-h484-3578, GO-2025-4070, MINI-w34j-hg35-wmg4

## What is CVE-2025-11621?

CVE-2025-11621 is a high-severity authentication bypass vulnerability in Hashicorp Vault, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vault and Vault Enterprise’s (“Vault”) AWS Auth method may be susceptible to authentication bypass if the role of the configured bound_principal_iam is the same across AWS accounts, or uses a wildcard. This vulnerability, CVE-2025-11621, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.21.0, 1.20.5, 1.19.11, and 1.16.27

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-11621?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 0.6.0 | 1.21.0 |
| `github.com/hashicorp/vault` | Go | From 0.6.0 | 1.21.0 |
| `github.com/hashicorp/vault` | Go | From 0.6.0 | 1.21.0 |
| `vault` | Bitnami | From 0.6.0 | 1.21.0 |

Products: Hashicorp Vault.

## How do I fix CVE-2025-11621?

Upgrade github.com/hashicorp/vault to 1.21.0 or later.

## Is CVE-2025-11621 being exploited?

There is no known exploitation of CVE-2025-11621 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11621 and fix it if it is affected.

What it is: CVE-2025-11621 is a high-severity authentication bypass vulnerability in Hashicorp Vault, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-11621 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 0.6.0; fixed in 1.21.0
- github.com/hashicorp/vault (Go): affected from 0.6.0; fixed in 1.21.0
- github.com/hashicorp/vault (Go): affected from 0.6.0; fixed in 1.21.0
- vault (Bitnami): affected from 0.6.0; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11621/ (Markdown: https://insights.sbomify.com/CVE-2025-11621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11621
- OSV: https://osv.dev/vulnerability/CVE-2025-11621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11621/
Summaries are generated and may contain mistakes; the official description above is the record.
