# CVE-2025-11687: Gi-docgen: reflected dom xss in gi-docgen

> Attackers can execute arbitrary JavaScript via a crafted URL in gi-docgen, enabling session cookie theft and DOM access.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 26 Jan 2026
- **Also known as:** AZL-110336, DEBIAN-CVE-2025-11687, GHSA-6p6h-rqr6-62mv, MINI-87hw-qhcr-c3p2, OESA-2026-4316, OESA-2026-4317, OESA-2026-4318, OESA-2026-4319, PYSEC-2026-1402, SUSE-SU-2026:21159-1, UBUNTU-CVE-2025-11687, openSUSE-SU-2025:15634-1, openSUSE-SU-2026:11185-1, openSUSE-SU-2026:20497-1

## What is CVE-2025-11687?

CVE-2025-11687 is a medium-severity cross-site scripting vulnerability in gi-docgen, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in the gi-docgen. This vulnerability allows arbitrary JavaScript execution in the context of the page — enabling DOM access, session cookie theft and other client-side attacks — via a crafted URL that supplies a malicious value to the q GET parameter (reflected DOM XSS).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-11687?

3 open source packages ship an affected version, including gi-docgen.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gi-docgen` | PyPI | All versions | 2025.5 |
| `gi-docgen` | PyPI | All versions | 2025.5 |
| `gi-docgen` | PyPI | All versions | 2025.5 |
| `python-gi-docgen` | SUSE:Linux Enterprise Server 16.0 | All versions | 2025.5-160000.1.1 |
| `python-gi-docgen` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 2025.5-160000.1.1 |
| `python-gi-docgen` | openSUSE:Leap 16.0 | All versions | 2025.5-160000.1.1 |
| `gi-docgen` | openSUSE:Tumbleweed | All versions | 2026.1-1.1 |
| `python-gi-docgen` | openSUSE:Tumbleweed | All versions | 2025.5-1.1 |

## How do I fix CVE-2025-11687?

Upgrade gi-docgen to 2025.5 or later.

## Is CVE-2025-11687 being exploited?

There is no known exploitation of CVE-2025-11687 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-11687 and fix it if it is affected.

What it is: CVE-2025-11687 is a medium-severity cross-site scripting vulnerability in gi-docgen, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-11687 in the wild and no public exploit code.

Affected packages and fixed versions:
- gi-docgen (PyPI): affected all versions; fixed in 2025.5
- gi-docgen (PyPI): affected all versions; fixed in 2025.5
- gi-docgen (PyPI): affected all versions; fixed in 2025.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-11687/ (Markdown: https://insights.sbomify.com/CVE-2025-11687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-11687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-11687
- OSV: https://osv.dev/vulnerability/CVE-2025-11687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-11687/
Summaries are generated and may contain mistakes; the official description above is the record.
