CVE-2025-11702 Missing Authorization in GitLab
An authenticated attacker with specific permissions can hijack project runners from other projects in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-11702?
CVE-2025-11702 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 29 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GitLab has remediated an issue in EE affecting all versions from 17.1 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an authenticated attacker with specific permissions to hijack project runners from other projects.
Weakness: CWE-862
Which versions are affected by CVE-2025-11702?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.1.0 | 18.3.5, 18.4.3, 18.5.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-11702?
Upgrade gitlab to a fixed version for your release line: 18.3.5, 18.4.3 or 18.5.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-11702 being exploited?
There is no known exploitation of CVE-2025-11702 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-11702, GHSA-9hv7-pg48-7596, UBUNTU-CVE-2025-11702.